22Re will not stay running

Discussion in '79-95 Toyota Truck Tech' started by 4WDBetterthan2feet, Nov 30, 2009.

  1. 4WDBetterthan2feet

    4WDBetterthan2feet

    Joined:
    Mar 27, 2007
    Messages:
    570
    Location:
    Columbus, OH
    I am think about checking out a 89 runner but the seller states it starts but will only run for 5-10 secs before shutting down. Anyone know what the likely culprit is with this type of problem. Is it a common problem with an easy fix? TIA.
     
  2. KLF

    KLF Frame waxer

    Joined:
    Apr 5, 2003
    Messages:
    5,594
    Location:
    Southern NH
    Open Circuit Relay (under the pass side kick panel), or the MAF sensor on top of the air box.

    Take a paper clip with you, bend it into a U shape. Find the Diagnostic connector under the hood, behind the battery. Jumper across the B+ and Fp cpntacts, then see if it stays running.
     
  3. 4WDBetterthan2feet

    4WDBetterthan2feet

    Joined:
    Mar 27, 2007
    Messages:
    570
    Location:
    Columbus, OH
    Thanks.
     
  4. pappy

    pappy photosynthesizing Moderator

    Joined:
    Oct 7, 2003
    Messages:
    7,257
    Location:
    Palm trees and cool streams
    Also consider the fuel pump.
     
  5. DanS HJ-45

    DanS HJ-45 SILVER Star

    Joined:
    Apr 26, 2007
    Messages:
    4,186
    Location:
    Idaho Springs, CO
  6. thetrekkerguy

    thetrekkerguy

    Joined:
    Nov 5, 2008
    Messages:
    297
    Location:
    waukesha wi
    dont forget about the resistor on the passanger side fender well. if the truck only runs for a few seconds it may be running on the cold start injector. also as stated above the check relay
     
  7. cruiser88

    cruiser88

    Joined:
    Feb 21, 2006
    Messages:
    11,886
    Location:
    WV
    did you ever check the codes on your old 62........you do it basicly the same way?
     
  8. corax

    corax

    Joined:
    Feb 12, 2009
    Messages:
    297
    Location:
    Eugene, OR
  9. 4WDBetterthan2feet

    4WDBetterthan2feet

    Joined:
    Mar 27, 2007
    Messages:
    570
    Location:
    Columbus, OH
    Thanks everyone. I was to slow. Called and left the guy a message to come look at it and I never heard back from him and the CL post disappeard. He was asking \ 1k and the truck was from texas. I was hoping to pick it up for a song considering it was not running but someone obviously go to the guy before me.
     

Share This Page